Recommended Browser and System Requirements


  • Any web browser that was made in the last 10 years can be used to access the LMS.
  • JavaScript is highly recommended but not required. JavaScript 1.2+ support would be recommended.
  • CSS 2.0 support is also highly recommended but not required.
  • CourseStage does not need a JRE installed.
  • CourseStage also does not have any requirements for computing power, screen resolution, or hard drive space. — Those requirements should be determined by what content is being served through CourseStage.


Tested and Verified Browser Compatibility:

Internet Explorer 9.x or later on Vista/ Windows XP

Firefox 30.x or later on Vista/Windows XP/ Linux

Safari 6.x or later on Vista/Windows XP/ OS X

Chrome 15.x or later on Windows XP/ Vista/ OS X/ Linux*

* Due to Chrome’s auto-update functionality, the latest version of Google Chrome is being tested at all times.


If you have any further questions or concerns about this information, please feel free to reach out to support@nicheprogram.org